p2p.org is down due to the outage at hosting provider
Resolved·Full outage

The website has been fully restored to its original state. It may take some time for changes to propagate completely. If you still see this message when trying to access the site, please refresh the page or try again later.

Mon, Oct 20, 2025, 08:53 PM
(1 month ago)
·
Affected components
Website
Updates

Resolved

The website has been fully restored to its original state. It may take some time for changes to propagate completely. If you still see this message when trying to access the site, please refresh the page or try again later.

Mon, Oct 20, 2025, 08:53 PM

Monitoring

The issue is no longer reproducible from multiple global locations and across all available devices. Final checks are currently being performed before restoring the website to its original state.

Mon, Oct 20, 2025, 08:26 PM(26 minutes earlier)

Monitoring

We’re observing early signs of recovery on the website. If performance remains stable over the next 1 hour, we’ll proceed with restoring the site to its original environment.

Mon, Oct 20, 2025, 07:02 PM(1 hour earlier)

Monitoring

The P2P.org website is currently experiencing an outage related to an ongoing issue. All other P2P.org products and services remain fully operational and unaffected. The incident is being actively monitored, and all available mitigation steps on our side have already been taken. The team will continue to track the status closely until full service is restored.

Mon, Oct 20, 2025, 04:25 PM(2 hours earlier)

Monitoring

The P2P.org website is currently experiencing an outage related to an ongoing issue. All other P2P.org products and services remain fully operational and unaffected. The incident is being actively monitored, and all available mitigation steps on our side have already been taken. The team will continue to track the status closely until full service is restored.

Mon, Oct 20, 2025, 04:20 PM
Powered by

The metrics, figures, and percentages displayed on this page are provided for informational purposes only and do not constitute, and shall not be construed as, any promise, warranty, guarantee, or representation, whether express or implied, by P2P or any of its affiliates. All such metrics are derived using specific internal methodologies and data aggregation practices, which may be revised, updated, or replaced at P2P’s sole discretion. Results derived from alternative metrics or calculation methods may vary significantly.

P2P does not guarantee that all incidents or service disruptions will be reported on this page. In particular, P2P reserves the right to withhold or delay disclosure of any incident information that, in its reasonable opinion, could compromise the confidentiality of sensitive data, operational security, or proprietary systems. Where applicable, client-specific notifications may be issued through the communication channels defined in the relevant service agreement or contractual framework.

Incident reports and related updates published on this page are non-exhaustive, may be subject to change without notice, and do not constitute a complete or definitive explanation of events. All content is provided “as is,” and should not be relied upon for making business, operational, legal, or investment decisions. By accessing this page, you acknowledge and agree that P2P shall not be held liable for any loss, damage, or decision arising from your reliance on the information presented herein.

For further information regarding the terms that govern your use of this website and the data displayed, please refer to our Terms of Use.