Elevated latency in Ethereum data across the Data API and Hub Staking Dashboard
Resolved·Degraded performance

Fresh Ethereum data has been restored on the Hub Staking Dashboard. Systems are fully up to date and performing as expected.

Wed, Nov 26, 2025, 11:56 AM
(1 week ago)
·
Affected components
API
P2P.org Hub
Updates

Resolved

Fresh Ethereum data has been restored on the Hub Staking Dashboard. Systems are fully up to date and performing as expected.

Wed, Nov 26, 2025, 11:56 AM

Identified

The raw data source for Ethereum blocks and transactions has been switched to a new public dataset that provides up-to-date data. The pipeline was recalculated to backfill the two-day gap, and the Data API are now current. We are now focused on bringing the fresh Ethereum data on Hub Staking Dashboard

Wed, Nov 26, 2025, 09:45 AM(2 hours earlier)

Identified

We are aware of an  issue affecting the Staking Data API and the Hub staking dashboard. Ethereum data is coming through with increased latency, and fresh data isn’t currently available. The engineering team has been dispatched to prepare and execute a mitigation plan.

Sat, Nov 22, 2025, 11:03 PM(3 days earlier)
Powered by

The metrics, figures, and percentages displayed on this page are provided for informational purposes only and do not constitute, and shall not be construed as, any promise, warranty, guarantee, or representation, whether express or implied, by P2P or any of its affiliates. All such metrics are derived using specific internal methodologies and data aggregation practices, which may be revised, updated, or replaced at P2P’s sole discretion. Results derived from alternative metrics or calculation methods may vary significantly.

P2P does not guarantee that all incidents or service disruptions will be reported on this page. In particular, P2P reserves the right to withhold or delay disclosure of any incident information that, in its reasonable opinion, could compromise the confidentiality of sensitive data, operational security, or proprietary systems. Where applicable, client-specific notifications may be issued through the communication channels defined in the relevant service agreement or contractual framework.

Incident reports and related updates published on this page are non-exhaustive, may be subject to change without notice, and do not constitute a complete or definitive explanation of events. All content is provided “as is,” and should not be relied upon for making business, operational, legal, or investment decisions. By accessing this page, you acknowledge and agree that P2P shall not be held liable for any loss, damage, or decision arising from your reliance on the information presented herein.

For further information regarding the terms that govern your use of this website and the data displayed, please refer to our Terms of Use.